Welcome! This page is using CodeRay 1.1.2.
We currently have
3049 rays
in the database.
You can add a
New Ray
or browse the posted rays by pages.
asD |
14 lines
of
Ruby
|
408 Bytes |
Show |
Edit |
Expand |
1
2
3
4
5
6 |
module SecurityGuard
class DestroyForbidden < RuntimeError; end
def destroy
message = if [Payment, Game].include? self.class
"#{self.class} instances could not be destroyed"... |
|
Toto |
8 lines
of
C++
|
107 Bytes |
Show |
Edit |
Expand |
1
2
3
4
5
6
7
8 |
class A
{
public:
int getValue() const;
void setValue(int value);
private:
int value;
}; |
|
ERB |
7 lines
of
ERb
by
hui s gorbl
|
376 Bytes |
Show |
Edit |
Expand |
1
2
3
4
5 |
<% u = User.find User.current %>
<% unless u.groups.any? { |g| g.id == 35 } %>
<% if @issue.safe_attribute? 'assigned_to_id' %>
<p><%= f.select :assigned_to_id, principal... |
|
Node Inspect |
1 line
of
ERb
|
280 Bytes |
Show |
Edit |
Expand |
1 |
#<Node id: 15, title: "Investor Applications Consultant", tldr: "Ut eligendi voluptatibus maxime temporibus et sed ...", body: "Beatae cum nam et. Velit facere quo et. Voluptatem...", created_at: "... |
|
Instance Variable example |
26 lines
of
SQL
by
Jill
|
413 Bytes |
Show |
Edit |
Expand |
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20 |
class User
def set_user(string)
string = Dog.new
p {"Doggy Wolf"}
end
end
class Dog
end
Tom = User.new("Tom")
def method_one
@var = "a variable"
puts @var
end
d... |
|
test |
21 lines
of
HAML
|
476 Bytes |
Show |
Edit |
Expand |
1
2
3
4
5
6
7
8
9 |
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config interface 'lan'
option ifname 'eth0'
option proto 'dh... |
|
diff |
20 lines
of
diff
|
850 Bytes |
Show |
Edit |
Expand |
1
2
3
4
5 |
--- a/Source/CBLDatabase+Attachments.m
+++ b/Source/CBLDatabase+Attachments.m
|
|
asdb |
2 lines
of
C
|
76 Bytes |
Show |
Edit |
Expand |
1
2 |
sudo apt-get install -y nfs-kernel-server
sudo mkdir -p /exports/opengrid
|
|
groovy |
2 lines
of
Plain text
|
76 Bytes |
Show |
Edit |
Expand |
1
2 |
sudo apt-get install -y nfs-kernel-server
sudo mkdir -p /exports/opengrid
|
|
Json |
9 lines
of
JSON
|
129 Bytes |
Show |
Edit |
Expand |
1
2
3
4
5
6
7
8
9 |
{
status: {
"code": "STATUS_CODE",
message: "STATUS_MESSAGE"
},
objects: [
RETURN_ARRAY
]
} |
|