Welcome! This page is using CodeRay 1.1.0 (beta).

We currently have 2166 rays in the database.
You can add a New Ray or browse the posted rays by pages.

Page 1, 10 entries

asdfasdf 4 lines of Java 135 Bytes Show Edit Expand
1
2
3
4
String string = "004-034556";
String[] parts = string.split("-");
String part1 = parts[0]; // 004
String part2 = parts[1]; // 034556
MS Ini File 2 lines of C 65 Bytes Show Edit Expand
1
2
[HKLM\Software\MyApp]
gpio_57="dir:out,lvl:1,AltFn:3,Pull:up10k"
asd 16 lines of Ruby 349 Bytes Show Edit Expand
1
2
3
4
5
6
7
a=ARGV[0]
require 'csv'
array=[]
Dir.glob("#{a}*.*")  do |my_text_file|
  name = my_text_file.split("/").last.split(".").first.split("_")  
  if name[1]!=nil && name[0].length==10
    array << nam...
asD 64 lines of Ruby 1.45 KB Show Edit Expand
1
2
3
4
5
6
7
8
9
10
#!/usr/local/bin/ruby -rubygems

require 'sinatra'
require 'dm-core'
require 'dm-validations'
require 'dm-timestamps'
require 'dm-migrations'
require 'syntaxi'

DataMapper.setup(:default, ...
Toto 8 lines of C++ 107 Bytes Show Edit Expand
1
2
3
4
5
6
7
8
class A
{
public:
    int getValue() const;
    void setValue(int value);
private:
    int value;
};
ERB 7 lines of ERb by hui s gorbl 376 Bytes Show Edit Expand
1
2
3
4
5
<!-- здесь -->
<% u = User.find User.current %>
<% unless u.groups.any? { |g| g.id == 35 } %>
  <% if @issue.safe_attribute? 'assigned_to_id' %>
      <p><%= f.select :assigned_to_id, principal...
Node Inspect 1 line of ERb 280 Bytes Show Edit Expand
1
#<Node id: 15, title: "Investor Applications Consultant", tldr: "Ut eligendi voluptatibus maxime temporibus et sed ...", body: "Beatae cum nam et. Velit facere quo et. Voluptatem...", created_at: "...
Instance Variable example 26 lines of SQL by Jill 413 Bytes Show Edit Expand
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
class User
  def set_user(string)
  string = Dog.new

  p {"Doggy Wolf"}
  end
end

class Dog
end

Tom = User.new("Tom")


def method_one
  @var = "a variable"
  puts @var
end

d...
test 21 lines of HAML 476 Bytes Show Edit Expand
1
2
3
4
5
6
7
8
9
config interface 'loopback'
  option ifname 'lo'
  option proto 'static'
  option ipaddr '127.0.0.1'
  option netmask '255.0.0.0'

config interface 'lan'
  option ifname 'eth0'
  option proto 'dh...
diff 20 lines of diff 850 Bytes Show Edit Expand
1
2
3
4
5
diff --git a/Source/CBLDatabase+Attachments.m b/Source/CBLDatabase+Attachments.m
index 618168e..0480fbd 100644
--- a/Source/CBLDatabase+Attachments.m
+++ b/Source/CBLDatabase+Attachments.m
@@ -...

Page 1, 10 entries